Project

General

Profile

Bug #21510

rails 5.0 deprecation of several app server config options

Added by Tomer Brisker about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Rails
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

DEPRECATION WARNING: `config.serve_static_files` is deprecated and will be removed in Rails 5.1.
Please use `config.public_file_server.enabled` instead.
 (called from <class:Application> at /home/tbrisker/foreman/config/application.rb:218)
DEPRECATION WARNING: `config.serve_static_files` is deprecated and will be removed in Rails 5.1.
Please use `config.public_file_server.enabled = true` instead.
 (called from block in <top (required)> at /home/tbrisker/foreman/config/environments/test.rb:21)
DEPRECATION WARNING: `config.static_cache_control` is deprecated and will be removed in Rails 5.1.
Please use
`config.public_file_server.headers = { 'Cache-Control' => 'public, max-age=3600' }`
instead.
 (called from block in <top (required)> at /home/tbrisker/foreman/config/environments/test.rb:22)


Related issues

Is duplicate of Foreman - Refactor #21097: remove settings deprecated by Rails 5.0Closed2017-09-25

History

#1 Updated by The Foreman Bot about 3 years ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4965 added

#2 Updated by Anonymous about 3 years ago

IMHO this does duplicate #21097

#3 Updated by Tomer Brisker about 3 years ago

  • Related to Refactor #21097: remove settings deprecated by Rails 5.0 added

#4 Updated by Tomer Brisker about 3 years ago

  • Status changed from Ready For Testing to Duplicate

#5 Updated by Tomer Brisker about 3 years ago

  • Related to deleted (Refactor #21097: remove settings deprecated by Rails 5.0)

#6 Updated by Tomer Brisker about 3 years ago

  • Is duplicate of Refactor #21097: remove settings deprecated by Rails 5.0 added

Also available in: Atom PDF