Project

General

Profile

Bug #21660

Guests of Hypervisor link not showing for guest subscriptions

Added by John Mitsch about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

To reproduce:
Setup VDC subscription w/ hypervisor and register a guest
Check Subscriptions page and notice there is no "Guests of" link

Associated revisions

Revision c0d72eb7 (diff)
Added by John Mitsch about 4 years ago

Fixes #21660 - Subscription's "guests of" link

The "guests of <hypervisor>" link was broken because
we changed the subscription API to no longer return hosts.
This commit will grab the "requires_host" value from
candlepin and adds that to a new field on the pools table,
"hypervisor_id". This can then be referenced by UI, which
will display the associated hypervisor.

To test you will need to register a VDC subscription and a
hypervisor running virt-who w/ guests.

History

#1 Updated by John Mitsch about 4 years ago

  • Bugzilla link set to 1382090

#2 Updated by John Mitsch about 4 years ago

  • Assignee set to John Mitsch
  • Category set to Subscriptions

#3 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7065 added

#4 Updated by Justin Sherrill about 4 years ago

  • Legacy Backlogs Release (now unused) set to 329

#5 Updated by John Mitsch about 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF