Project

General

Profile

Bug #21665

Host creation form bounces from synced content to media not found

Added by Daniel Lobato Garcia about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The Host::Managed media validator has always been overridden by Katello, as Synced content does not need installation media to work.
Check out the following gif for an example:

The problem is that https://github.com/Katello/katello/commit/a32a9be522015a1ef925038ca2cf94722efb6307#diff-4a41cc0011db848f8d1bc5025f997d12R9 renamed the override from "validate_media?" to "validate_media" (no question mark).
Renaming that and adding some tests to ensure hosts with synced content.

Associated revisions

Revision 3bf503ce (diff)
Added by Daniel Lobato Garcia about 4 years ago

Fixes #21665 - Override Host validate_media? properly

History

#1 Updated by The Foreman Bot about 4 years ago

  • Assignee set to Daniel Lobato Garcia
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7062 added

#2 Updated by Justin Sherrill about 4 years ago

  • Legacy Backlogs Release (now unused) set to 329

#3 Updated by Anonymous about 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF