Project

General

Profile

Bug #21708

upgrade to satellite 6.3 beta wont work if ssl.conf is missing

Added by Chris Roberts almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
if there is an update to the modssl/httpd package and you upgrade to 6.3 and ssl.conf is not present the upgrade will fail with httpd not being able to start.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install satellite 6.2
2. rm -rf ssl.conf file in http conf dir
3. upgrade to 6.3 with an upgrade to httpd/modssl
4. run upgrade

Actual results:

httpd wont start since dual listen 443 in ssl.conf and ports.conf

Expected results:

upgrade to go through

Additional info:

Associated revisions

Revision 549cf61e (diff)
Added by Chris Roberts almost 2 years ago

Fixes #21708 - remove services starting on upgrade

History

#1 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/566 added

#2 Updated by Chris Roberts almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#3 Updated by Justin Sherrill almost 2 years ago

  • Legacy Backlogs Release (now unused) set to 250

#4 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/568 added

#5 Updated by Andrew Kofink almost 2 years ago

  • Pull request deleted (https://github.com/Katello/katello-installer/pull/568)

Also available in: Atom PDF