Project

General

Profile

Bug #2189

Problem searching for host params "inherited" from the hostgrup

Added by Oscar Ferrer almost 7 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Search
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I've found this problem (at least) in 1.1RC5 and 1.1

How to reproduce it:
- Create a hostgroup A with a parameter foo=bar,
- Create a hostgrup B whose parent is A.
- Create a host foreman-rules and assign B as its hostgroup.
- Now search for all the host that match param.foo=bar (using the web interface for instance). You will get an empty list.
- Overwrite foo param in hostgroup B or in host foreman-rules, the search works perfeclty.

It seems that I can only search for params that are defined in the host or in the hostgroup that it's assigned but not deep in the hostgroup hierarchy.


Related issues

Related to Foreman - Bug #1804: Class filter in host page does not show inherited class from nested hostgroupClosed2012-08-02
Related to Foreman - Feature #2263: search Hostgroup by label Closed2013-02-28
Is duplicate of Foreman - Bug #2871: Foreman scoped_search on hosts params only search for boolean parametersClosed2013-08-02

Associated revisions

Revision e5b861e3 (diff)
Added by Dominic Cleal almost 6 years ago

refs #2189 - update host group parameter search tests

History

#1 Updated by Clemens Bergmann almost 7 years ago

hi there,

I can confirm this.
I can also say that this is not only for parameters but for any search. My problem is the search for puppet classes.
If Hostgroup A has class C and is the parent of Hostgroup B.
And if Host H is member of Hostgroup B.
If you then search for "class = C" the result does not include Host H.

#2 Updated by Dominic Cleal almost 7 years ago

  • Category set to Search

This is a very similar issue to what is described in #1804.

#3 Updated by Dominic Cleal almost 6 years ago

  • Is duplicate of Bug #2871: Foreman scoped_search on hosts params only search for boolean parameters added

#4 Updated by Dominic Cleal almost 6 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

This has been fixed in Foreman 1.3.0 via #2871.

Also available in: Atom PDF