Project

General

Profile

Feature #21918

Remove jquery-ui-spinner and move to a react implementation

Added by Avi Sharvit over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

jquery-ui-spinner:
https://jqueryui.com/spinner/

The name is confusing, the jquery-ui-spinner is a numeric form field.

Use it in:
https://github.com/theforeman/foreman/blob/8f7f710cbe4b95e924cb8fd971f47617d234eba1/webpack/assets/javascripts/jquery.ui.custom_spinners.js

Need to change it to be a react component so it will be easier to upgrade to jquery-v3 and easier get ride of jquery at the end.


Related issues

Related to Foreman - Feature #29900: Add cpu/cores/socket react componentClosed
Related to Foreman - Feature #30288: replace the existing CPU/Cores/Socket inputClosed
Is duplicate of Foreman - Refactor #21641: Drop jquery-ui spinners in favor of React imlementationClosed

History

#1 Updated by Tomer Brisker over 3 years ago

  • Status changed from New to Duplicate

#2 Updated by Tomer Brisker over 3 years ago

  • Is duplicate of Refactor #21641: Drop jquery-ui spinners in favor of React imlementation added

#3 Updated by yifat makias about 1 year ago

  • Related to Feature #29900: Add cpu/cores/socket react component added

#4 Updated by yifat makias about 1 year ago

  • Related to Feature #29964: Add memory allocation react cmponent added

#5 Updated by yifat makias about 1 year ago

  • Related to Feature #30288: replace the existing CPU/Cores/Socket input added

#6 Updated by Ondřej Ezr 4 months ago

  • Related to deleted (Feature #29964: Add memory allocation react cmponent)

Also available in: Atom PDF