Project

General

Profile

Bug #21935

No notification of discovered host for user with "Organization admin" role

Added by Marek Hulán about 5 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Normal
Category:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1517731

Description of problem: We created a user with "Organization admin" role and logged in with created user. We discovered a host in an organization. But, notification drawer didn't notify regarding discovered host.

Version-Release number of selected component (if applicable): Satellite 6.3 snap 26

How reproducible: always

Steps to Reproduce:
1. Login with admin
2. Navigate to Administer -> Users
3. Create user providing location, organization and "Organization admin" role
4. Navigate to Administer -> settings -> Discovered
5. Set Discovery organization and location
5. Login with created user
6. Discovered a host
7. Verify host is discovered under Hosts -> discovered host

Actual results:
No notification regarding discovered host in notification drawer.

Expected results:
There should be notification in notification drawer.

Additional info:
Admin user get notification regarding discovered host.

Associated revisions

Revision 5508290d (diff)
Added by Daniel Lobato Garcia almost 5 years ago

Fixes #21935 - Notifications for org admins too

Before this commit, the notifications for new discovered host were only
seen by admins (global admins). However, the organization admins should
also be able to see these notifications.

History

#1 Updated by The Foreman Bot about 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_discovery/pull/398 added

#2 Updated by Anonymous almost 5 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#3 Updated by Lukas Zapletal almost 4 years ago

  • Triaged changed from No to Yes
  • Status changed from Closed to New
  • Subject changed from No notification of discovered host for user with "Organization admin" role to No notification of discovered host for user with "Organization admin" role
  • Fixed in Releases Discovery Plugin 12.0.2 added

The fix was reported not to work correctly. Flipping back to NEW.

#4 Updated by Bryan Kearney almost 3 years ago

  • Pull request deleted (https://github.com/theforeman/foreman_discovery/pull/398)

Removing the PR https://github.com/theforeman/foreman_discovery/pull/398 since that did not fix it.

Also available in: Atom PDF