Project

General

Profile

Refactor #21938

Single upgrade rake task

Added by Ewoud Kohl van Wijngaarden about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
rake tasks
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently there are many rake tasks for upgrades that are called one-by-one in the installer. This means that for every upgrade step we need to write code for an additional task. I'd be much easier if there was a single task that wrapped all katello:upgrades:* tasks so we could simply do foreman-rake katello:upgrade.


Related issues

Is duplicate of Katello - Bug #22961: re-vamp upgrade proccess to not require installer updatesDuplicate
Blocks Katello - Tracker #23927: Convert sync plans to Foreman TasksClosed

Blocks Katello - Refactor #24189: Update katello to use foreman upgrade taskClosed

Associated revisions

Revision d93cd014 (diff)
Added by Justin Sherrill 3 months ago

Fixes #21938 - add plugable upgrade rake task

This commit adds the ability for upgrade rake tasks to be defined
within seeds. The installer can then run the upgrade:run rake task
to run them. Tasks can be defined to run once or to always run when
the upgrade:run master task is run.

History

#1 Updated by Andrew Kofink about 1 year ago

  • Legacy Backlogs Release (now unused) set to 284

#2 Updated by Andrew Kofink about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 284 to 114
  • Category set to Upgrades

#3 Updated by Justin Sherrill 11 months ago

  • Legacy Backlogs Release (now unused) changed from 114 to 338

#4 Updated by Justin Sherrill 6 months ago

  • Is duplicate of Bug #22961: re-vamp upgrade proccess to not require installer updates added

#5 Updated by Justin Sherrill 6 months ago

#6 Updated by Justin Sherrill 6 months ago

  • Status changed from New to Duplicate

#7 Updated by Justin Sherrill 5 months ago

  • Triaged set to No
  • Legacy Backlogs Release (now unused) deleted (338)
  • Assignee set to Justin Sherrill
  • Category changed from Upgrades to rake tasks
  • Project changed from Katello to Foreman

#8 Updated by Justin Sherrill 5 months ago

  • Status changed from Duplicate to New

#9 Updated by Justin Sherrill 5 months ago

#10 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5780 added

#11 Updated by Justin Sherrill 3 months ago

  • Status changed from Ready For Testing to Closed

#12 Updated by Marek Hulán 3 months ago

  • Fixed in Releases 1.20.0 added

Also available in: Atom PDF