Project

General

Profile

Bug #21981

Error creating a lifecycle environment

Added by John Mitsch over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Lifecycle Environments
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

latest upstream/master

To reproduce, create a lifecycle environment

Traceback:
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] Resource GET request: /candlepin/owners/Default_Organization
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] Headers: {"accept":"application/json","cp-user":"foreman_admin"}
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] Body: {}
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] Candlepin request 34934e15-fb6a-44ea-8b74-e84bef6a4e43 returned with code 200
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] Processing response: 200
2017-12-14T16:11:01 af9e9fc4 [katello/cp_rest] [D] {"parentOwner":null,"id":"4028f99e602d58e101602d5f17250001","key":"Default_Organization","displayName":"Default Organization","contentPrefix":"/Def
ault_Organization/$env","defaultServiceLevel":null,"upstreamConsumer":null,"logLevel":null,"autobindDisabled":null,"contentAccessMode":"entitlement","contentAccessModeList":"entitlement","href":"/ow
ners/Default_Organization","created":"2017-12-06T19:48:14+0000","updated":"2017-12-06T19:48:14+0000"}
2017-12-14T16:11:03 d76fa16b [notifications] [D] Cache Hit: notification, reading cache for notification-4
2017-12-14T16:11:09 d7806052 [app] [E] ActionController::ParameterMissing: param is missing or the value is empty: prior_id | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/actionpack-5.0.6/lib/action_controller/metal/strong_parameters.rb:462:in `require' | /home/vagrant/katello/app/controllers/katello/api/v2/environments_controller.rb:152:in `find_prior'

History

#1 Updated by John Mitsch over 4 years ago

  • Status changed from New to Resolved

Looks like this is working now. If anyone else sees this please reopen

#2 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF