Project

General

Profile

Bug #21998

A user with "Organization admin" role is not able to list resources when specifing org id in api

Added by Tomer Brisker almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1517711

Description of problem:

A user with "Organization admin" role is not able to access "Content Hosts" page in the webui.

Version-Release number of selected component (if applicable):
Satellite v 6.3 Beta SNAP 26

How reproducible:
Always

Steps to Reproduce:
1. Create a new user with "Organization Admin" role
2. Try to access Content Hosts

Actual results:
The Org Admin user is able to list system profiles in the "All Hosts" page but not able to access list any system profiles on the "Content Hosts" page.

Expected results:
Org Admin user should have access to list and manage content hosts, he should be able to set/change/remove Environment/Content View/Subscriptions etc to the system profile.


Related issues

Is duplicate of Foreman - Bug #21343: Organization admin should he able to work with full multitenancyClosed2017-10-16

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5093 added

#2 Updated by Tomer Brisker almost 3 years ago

  • Status changed from Ready For Testing to Duplicate
  • Subject changed from A user with "Organization admin" role is not able to list resources when specifing org id in api to A user with "Organization admin" role is not able to list resources when specifing org id in api

#3 Updated by Tomer Brisker almost 3 years ago

  • Is duplicate of Bug #21343: Organization admin should he able to work with full multitenancy added

Also available in: Atom PDF