Project

General

Profile

Bug #22007

foreman-rake db:migrate - upgrate to katello 3.5

Added by Denis Müller over 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Upgrades
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Maybe somebody can help:

@[root@theforeman ~]# foreman-installer --scenario katello --upgrade --verbose
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group pre_migrations
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group pre_migrations finished
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group boot
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group boot finished
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group init
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group init finished
[ INFO 2017-12-18 09:43:01 verbose] Loading default values from puppet modules...
[ INFO 2017-12-18 09:43:01 verbose] ... finished
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group pre_values
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group pre_values finished
[ INFO 2017-12-18 09:43:01 verbose] Running installer with args "--scenario", "katello", "--upgrade", "--verbose"
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group pre_validations
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group pre_validations finished
[ INFO 2017-12-18 09:43:01 verbose] Running validation checks
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group pre_commit
[ INFO 2017-12-18 09:43:01 verbose] All hooks in group pre_commit finished
[ INFO 2017-12-18 09:43:01 verbose] Executing hooks in group pre
Upgrading, to monitor the progress on all related services, please do:
[ INFO 2017-12-18 09:43:01 verbose] Upgrading, to monitor the progress on all related services, please do:
foreman-tail | tee upgrade-$(date +%Y-%m-%d-%H%M).log
[ INFO 2017-12-18 09:43:01 verbose] foreman-tail | tee upgrade-$(date +%Y-%m-%d-%H%M).log
Upgrade Step: stop_services...
[ INFO 2017-12-18 09:43:04 verbose] Upgrade Step: stop_services...
/usr/sbin/service-wait goferd stop

/usr/sbin/service-wait foreman-tasks stop

/usr/sbin/service-wait puppetserver stop

/usr/sbin/service-wait httpd stop

/usr/sbin/service-wait pulp_celerybeat stop

/usr/sbin/service-wait foreman-proxy stop

/usr/sbin/service-wait pulp_streamer stop

/usr/sbin/service-wait pulp_resource_manager stop

/usr/sbin/service-wait smart_proxy_dynflow_core stop

/usr/sbin/service-wait pulp_workers stop

/usr/sbin/service-wait tomcat stop

/usr/sbin/service-wait squid stop

/usr/sbin/service-wait qdrouterd stop

/usr/sbin/service-wait qpidd stop

Success!
katello-service stop --exclude mongod,postgresql finished successfully!
Upgrade Step: start_databases...
[ INFO 2017-12-18 09:43:06 verbose] Upgrade Step: start_databases...
/usr/sbin/service-wait mongod start

/usr/sbin/service-wait postgresql start

Success!
katello-service start --only mongod,postgresql finished successfully!
Upgrade Step: update_http_conf...
[ INFO 2017-12-18 09:43:16 verbose] Upgrade Step: update_http_conf...
grep -F -q 'Include "/etc/httpd/conf.modules.d/*.conf"' /etc/httpd/conf/httpd.conf || echo -e '<IfVersion >= 2.4>
Include "/etc/httpd/conf.modules.d/*.conf"
</IfVersion>' >> /etc/httpd/conf/httpd.conf finished successfully!
Upgrade Step: migrate_pulp...
[ INFO 2017-12-18 09:43:16 verbose] Upgrade Step: migrate_pulp...
grep -qe '7.:digit:' /etc/redhat-release finished successfully!
sed -i -e 's?/var/run/mongodb/mongodb.pid?/var/run/mongodb/mongod.pid?g' /etc/mongod.conf finished successfully!
13327
pgrep mongod finished successfully!
Attempting to connect to localhost:27017
Attempting to connect to localhost:27017
Write concern for Mongo connection: {}
Loading content types.
Loading type descriptors []
Parsing type descriptors
Validating type descriptor syntactic integrity
Validating type descriptor semantic integrity
Loading unit model: puppet_module = pulp_puppet.plugins.db.models:Module
Loading unit model: ostree = pulp_ostree.plugins.db.model:Branch
Loading unit model: docker_blob = pulp_docker.plugins.models:Blob
Loading unit model: docker_manifest = pulp_docker.plugins.models:Manifest
Loading unit model: docker_image = pulp_docker.plugins.models:Image
Loading unit model: docker_tag = pulp_docker.plugins.models:Tag
Loading unit model: erratum = pulp_rpm.plugins.db.models:Errata
Loading unit model: distribution = pulp_rpm.plugins.db.models:Distribution
Loading unit model: srpm = pulp_rpm.plugins.db.models:SRPM
Loading unit model: package_group = pulp_rpm.plugins.db.models:PackageGroup
Loading unit model: package_category = pulp_rpm.plugins.db.models:PackageCategory
Loading unit model: iso = pulp_rpm.plugins.db.models:ISO
Loading unit model: package_environment = pulp_rpm.plugins.db.models:PackageEnvironment
Loading unit model: drpm = pulp_rpm.plugins.db.models:DRPM
Loading unit model: package_langpacks = pulp_rpm.plugins.db.models:PackageLangpacks
Loading unit model: rpm = pulp_rpm.plugins.db.models:RPM
Loading unit model: yum_repo_metadata_file = pulp_rpm.plugins.db.models:YumMetadataFile
Loading auxiliary model: erratum_pkglists = pulp_rpm.plugins.db.models:ErratumPkglist
Updating the database with types []
Found the following type definitions that were not present in the update collection [puppet_module, ostree, srpm, erratum, docker_blob, drpm, distribution, package_group, package_category, iso, package_environment, docker_tag, package_langpacks, rpm, yum_repo_metadata_file, docker_image, docker_manifest]
Updating the database with types [puppet_module, drpm, ostree, package_langpacks, docker_manifest, docker_blob, erratum, yum_repo_metadata_file, package_group, package_category, iso, package_environment, docker_tag, distribution, rpm, srpm, docker_image]
Content types loaded.
Ensuring the admin role and user are in place.
Admin role and user are in place.
Beginning database migrations.
Migration package pulp.server.db.migrations is up to date at version 28
Migration package pulp_docker.plugins.migrations is up to date at version 3
Migration package pulp_puppet.plugins.migrations is up to date at version 5
Migration package pulp_rpm.plugins.migrations is up to date at version 41
Loading unit model: puppet_module = pulp_puppet.plugins.db.models:Module
Loading unit model: ostree = pulp_ostree.plugins.db.model:Branch
Loading unit model: docker_blob = pulp_docker.plugins.models:Blob
Loading unit model: docker_manifest = pulp_docker.plugins.models:Manifest
Loading unit model: docker_image = pulp_docker.plugins.models:Image
Loading unit model: docker_tag = pulp_docker.plugins.models:Tag
Loading unit model: erratum = pulp_rpm.plugins.db.models:Errata
Loading unit model: distribution = pulp_rpm.plugins.db.models:Distribution
Loading unit model: srpm = pulp_rpm.plugins.db.models:SRPM
Loading unit model: package_group = pulp_rpm.plugins.db.models:PackageGroup
Loading unit model: package_category = pulp_rpm.plugins.db.models:PackageCategory
Loading unit model: iso = pulp_rpm.plugins.db.models:ISO
Loading unit model: package_environment = pulp_rpm.plugins.db.models:PackageEnvironment
Loading unit model: drpm = pulp_rpm.plugins.db.models:DRPM
Loading unit model: package_langpacks = pulp_rpm.plugins.db.models:PackageLangpacks
Loading unit model: rpm = pulp_rpm.plugins.db.models:RPM
Loading unit model: yum_repo_metadata_file = pulp_rpm.plugins.db.models:YumMetadataFile
Loading auxiliary model: erratum_pkglists = pulp_rpm.plugins.db.models:ErratumPkglist
Database migrations complete.
su - apache -s /bin/bash -c pulp-manage-db finished successfully!
Upgrade Step: migrate_candlepin...
[ INFO 2017-12-18 09:43:18 verbose] Upgrade Step: migrate_candlepin...
Configuring PostgreSQL with JDBC URL: jdbc:postgresql://localhost/candlepin
Migrating candlepin database
--driver=org.postgresql.Driver --classpath=/usr/share/java/postgresql-jdbc.jar:/var/lib/tomcat/webapps/candlepin/WEB-INF/classes/ --changeLogFile=db/changelog/changelog-update.xml --url=jdbc:postgresql://localhost/candlepin --username=candlepin --password=yaYJG3XAuSjWJF6QLkndmakmTJpqCwdy
Liquibase Update Successful
/usr/share/candlepin/cpdb --update --database '//localhost/candlepin' --user candlepin --password yaYJG3XAuSjWJF6QLkndmakmTJpqCwdy finished successfully!
Upgrade Step: migrate_foreman...
[ INFO 2017-12-18 09:43:20 verbose] Upgrade Step: migrate_foreman...
/usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
/usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
rake aborted!
TypeError: no implicit conversion of nil into String
/usr/share/foreman/config/initializers/assets.rb:73:in `join'
/usr/share/foreman/config/initializers/assets.rb:73:in `block (4 levels) in <top (required)>'
/usr/share/foreman/config/initializers/assets.rb:72:in `map'
/usr/share/foreman/config/initializers/assets.rb:72:in `block (3 levels) in <top (required)>'
/usr/share/foreman/config/initializers/assets.rb:69:in `each'
/usr/share/foreman/config/initializers/assets.rb:69:in `block (2 levels) in <top (required)>'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/lazy_load_hooks.rb:36:in `call'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/lazy_load_hooks.rb:36:in `execute_hook'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/lazy_load_hooks.rb:45:in `block in run_load_hooks'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/lazy_load_hooks.rb:44:in `each'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/lazy_load_hooks.rb:44:in `run_load_hooks'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application/finisher.rb:62:in `block in <module:Finisher>'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:30:in `instance_exec'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:30:in `run'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:55:in `block in run_initializers'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `each'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `tsort_each_child'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:54:in `run_initializers'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application.rb:352:in `initialize!'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in `public_send'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in `method_missing'
/usr/share/foreman/config/environment.rb:5:in `<top (required)>'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/polyglot-0.3.4/lib/polyglot.rb:65:in `require'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/dependencies.rb:274:in `block in require'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/dependencies.rb:240:in `load_dependency'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/dependencies.rb:274:in `require'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application.rb:328:in `require_environment!'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application.rb:457:in `block in run_tasks_blocks'
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)
foreman-rake db:migrate failed! Check the output for error!
[ERROR 2017-12-18 09:43:31 verbose] foreman-rake db:migrate failed! Check the output for error!
Upgrade step migrate_foreman failed. Check logs for more information.
[ERROR 2017-12-18 09:43:31 verbose] Upgrade step migrate_foreman failed. Check logs for more information.
[ INFO 2017-12-18 09:43:31 verbose] Installer finished in 31.183857718 seconds@

History

#1 Updated by Eric Helms over 4 years ago

  • Status changed from New to Need more information

Denis,

What version of Katello were you upgrading from?

#2 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166
  • Category set to Upgrades

Moving to recycle bin, please provide more information if you can.

#3 Updated by Justin Sherrill over 4 years ago

  • Status changed from Need more information to Rejected

Closing due to inactivity, feel free to reopen if you can reproduce and can provide the requested info. Thanks!

Also available in: Atom PDF