Project

General

Profile

Bug #22131

"undefined method `persisted?' for nil:NilClass" when creating a RHEV host

Added by Ori Rabin almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1498447

Description of problem:
Sometimes, when creating a new RHEV host through a dialog, after clicking submit and long waiting (probably related to some timeout), the error message is shown:

"Oops, we're sorry but something went wrong undefined method `persisted?' for nil:NilClass"

With the attached traceback.

Version-Release number of selected component (if applicable):
Reproduced on Sat6.3 snap 18.

How reproducible:
Sometimes, probably after timeout

Steps to Reproduce:
1. Hosts -> Create Host
2. Fill in the form, using RHEV computing resource as "Deploy on"
3. Submit

Actual results:
Error, traceback, operation fails

Expected results:
New host created

Associated revisions

Revision e2f7f37e (diff)
Added by Ori Rabin almost 3 years ago

Fixes #22131 - Refactor new_vm? to calculate compute_object once

History

#1 Updated by Ori Rabin almost 3 years ago

  • Target version set to 113
  • Assignee set to Ori Rabin
  • Status changed from New to Assigned

I was not able to reproduce but from the stacktrace it looks like the problem is here:
/usr/share/foreman/app/helpers/compute_resources_vms_helper.rb:220:in `new_vm?'

#2 Updated by The Foreman Bot almost 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5147 added

#3 Updated by Timo Goebel almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 296

#4 Updated by Ori Rabin almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF