Project

General

Profile

Feature #2214

Specifying host IP address should not be mandatory for unmanaged DNS/DHCP subnets

Added by Jon Fautley almost 6 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Host creation
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We have a setup whereby we deploy (RHEL) virtual machines (using libvirt+foreman) onto networks where we are only able to control the TFTP server via the smart-proxy.

When creating a new host, it is mandatory to specify an IP address for the primary interface of the new host - this should be made optional, and updated once the build is in progress.

Foreman already knows the MAC address of the system being built, so requests for the provision (kickstart) template are successful, and Foreman is then aware of the assigned IP for the host. Once Foreman is aware of the IP of the host, it should update the record in order for the 'build complete' status to be updated correctly.


Related issues

Related to Foreman - Feature #2576: Optionally update Host.ip as part of /unattended/builtClosed2013-05-28
Is duplicate of Foreman - Feature #3182: Remove requirement for entering an IP address when creating a new hostClosed2013-10-02

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Feature #3182: Remove requirement for entering an IP address when creating a new host added

#2 Updated by Dominic Cleal about 5 years ago

  • Related to Feature #2576: Optionally update Host.ip as part of /unattended/built added

#3 Updated by Dominic Cleal about 5 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

Being implemented via #3182.

Also available in: Atom PDF