Project

General

Profile

Bug #2215

When PXE Localboot Default is deleted, causes nil error when cancelling build

Added by Dominic Cleal almost 7 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
TFTP
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The following error is generated when TFTP PXELinux templates are deployed, but no template can be resolved:

Failed to generate PXELinux template: undefined method `template' for nil:NilClass

This can happen when the built in "PXE Localboot Default" template is removed. A better error message would be useful, and maybe a setting to allow the user to select another behaviour or template.


Related issues

Is duplicate of Foreman - Bug #2792: If you delete "PXE Localboot Default" cancel build failsNew2013-07-15

History

#1 Updated by Dominic Cleal about 6 years ago

  • Is duplicate of Bug #2792: If you delete "PXE Localboot Default" cancel build fails added

#2 Updated by Dominic Cleal about 6 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate
  • Assignee deleted (Ohad Levy)

Also available in: Atom PDF