Project

General

Profile

Bug #22154

RHV compute resource screen shows DataTables warning invalid json response

Added by Ori Rabin over 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1501927

Description of problem:
After creating a compute resource, it doesn't seem to be able to properly parse the output of the API calls. The "Virtual Machines" tab looks as well broken.

Version-Release number of selected component (if applicable):
satellite-6.3.0-19.0.beta.el7sat.noarch

How reproducible:
Each time I go to the RHEV's compute resource page, but I haven't checked if it happens with any RHV compute resource.

Steps to Reproduce:
1. hammer compute-resource create --datacenter Default --description "RHEV on my Laptop" --locations "Default Location" --name "cr-rhev-laptop" --organizations "Default Organization" --password ADMINPWD --provider Ovirt --url https://rhev.example.com/api --user 'admin@internal'
2. Go to the Satellite UI, Infrastructure -> Compute resources
3. Click on the compute resource's name

Actual results:
Error message dialog: DataTables warning: table id=DataTables_Table_0 - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1 (see screenshot).
Additionally the page with the VMs is empty and rather malformed (e.g. no page number, see 2nd screenshot).

Expected results:
No error message and the VMs are properly listed (there are two of them).

Additional info:
RHEV version 3.6 is used here.


Related issues

Related to Foreman - Bug #22155: Datacenter in API should be UUIDClosed

History

#1 Updated by Ori Rabin over 2 years ago

  • Target version set to 113
  • Assignee set to Ori Rabin
  • Status changed from New to Assigned

#2 Updated by Ori Rabin over 2 years ago

  • Related to Bug #22155: Datacenter in API should be UUID added

#3 Updated by Shira Maximov 10 months ago

  • Triaged set to No
  • Status changed from Assigned to Closed

closing since the issue was solved in: https://projects.theforeman.org/issues/22155

Also available in: Atom PDF