Project

General

Profile

Feature #22159

Whenever an audit is created, it should create a log entry with the information

Added by Marek Hulán over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Audit Log
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Whenever an audit is created, it should create a log entry with the information. The logger should be disabled by default, but it would be great to have a way to keep audit information in logs. Logs can be kept forever and imported to other tools such as ELK stack for further processing. So in audit after_create we should have do the logging.


Related issues

Related to Foreman - Tracker #21879: [TRACKER] Audit every possible resourceNew2017-12-06

Is duplicate of Foreman - Feature #6752: Audit Log FileClosed2014-07-23

History

#1 Updated by Marek Hulán over 2 years ago

  • Related to Tracker #21879: [TRACKER] Audit every possible resource added

#2 Updated by Tomer Brisker over 2 years ago

  • Status changed from New to Duplicate

#3 Updated by Tomer Brisker over 2 years ago

Also available in: Atom PDF