Project

General

Profile

Bug #22211

No count method defined for state stopped/planning/pending/scheduled

Added by Anurag Patel over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Copied from BZ

Description of problem: We were trying to run foreman-tasks-fetch-tasks-status with foreman-tasks-fetch-tasks-status. But for state stopped/planning/pending/scheduled (states other than pending/running), it shows error in foreman-maintain.log as "No count method defined for state".

Version-Release number of selected component (if applicable): foreman-maintain snap 3

  1. rpm -q rubygem-foreman_maintain
    rubygem-foreman_maintain-0.0.10-1.el7sat.noarch

How reproducible:always

Steps to Reproduce:
1.# foreman-maintain advanced procedure run foreman-tasks-fetch-tasks-status --state stopped

Actual results:

  1. foreman-maintain advanced procedure run foreman-tasks-fetch-tasks-status --state stopped
    Running ForemanMaintain::Scenario ================================================================================
    Fetch tasks status and wait till they finish:
    / Try checking status of stopped task(s) [OK]
    --------------------------------------------------------------------------------

But foreman-maintain.log shows

I, [2017-10-25 09:20:27-0400 #25041] INFO -- : Running foreman-maintain command with arguments "advanced", "procedure", "run", "foreman-tasks-fetch-tasks-status", "--state", "stopped"
E, [2017-10-25 09:20:27-0400 #25041] ERROR -- : No count method defined for state stopped.
E, [2017-10-25 09:20:27-0400 #25041] ERROR -- : Unsupported for state stopped.
I, [2017-10-25 09:20:27-0400 #25041] INFO -- : foreman-maintain command finished with

Expected results:foreman-tasks-fetch-tasks-status should work for all tasks

Additional info: foreman-maintain advanced procedure run foreman-tasks-fetch-tasks-status --state pending/running works.


Related issues

Related to Foreman Maintain - Bug #23102: Fix - hide foreman-tasks-fetch-tasks-status procedure through "adavced procedure run" comandClosed2018-04-03

History

#1 Updated by Anurag Patel about 1 year ago

  • Status changed from New to Closed

This is not a bug. Tracking this in http://projects.theforeman.org/issues/23102 to hide the option mentioned here.

#2 Updated by Anurag Patel about 1 year ago

  • Related to Bug #23102: Fix - hide foreman-tasks-fetch-tasks-status procedure through "adavced procedure run" comand added

Also available in: Atom PDF