Project

General

Profile

Bug #22227

Foreman maintain should not allow upgrading from least minor version to next major version

Added by Anurag Patel over 1 year ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

From Bugzilla:

Foreman maintain should not allow upgrading from least minor version to next major version for e.g: Currently foreman-maintain allows satellite upgrade from 6.2.1 to directly 6.3.0 which may lead to missing migration in the satellite.

Instead for upgrading directly to 6.3, It should follow the path

Satellite 6.2.x -> "6.2 latest" and then Satellite "6.2 latest" -> 6.3

History

#1 Updated by Anurag Patel over 1 year ago

  • Tracker changed from Feature to Bug

Also available in: Atom PDF