Project

General

Profile

Bug #22240

activation key repo sets fails with error wrong number of arguments (given 0, expected 1)

Added by Justin Sherrill over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

 
2018-01-10T20:49:17 31dfe8fc [app] [E] ActionView::Template::Error: wrong number of arguments (given 0, expected 1)
 | /home/vagrant/git/katello/app/models/katello/glue/candlepin/content.rb:7:in `modified_product_ids'
 | /home/vagrant/.rvm/gems/ruby-2.3.3/gems/rabl-0.13.1/lib/rabl/helpers.rb:16:in `data_object_attribute'
 | /home/vagrant/.rvm/gems/ruby-2.3.3/gems/rabl-0.13.1/lib/rabl/builder.rb:140:in `attribute'
 | /home/vagrant/.rvm/gems/ruby-2.3.3/gems/rabl-0.13.1/lib/rabl/builder.rb:114:in `block in compile_settings'

Associated revisions

Revision 9da1e12c (diff)
Added by Justin Sherrill over 3 years ago

Fixes #22240 - fix repo sets for akeys and content hosts

in addition, correctly save custom content
to be known to be enabled by default. Also
provides a way to reimport content and product content

History

#1 Updated by Justin Sherrill over 3 years ago

  • Description updated (diff)

#2 Updated by Justin Sherrill over 3 years ago

  • Target version set to 242

#3 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7145 added

#4 Updated by Justin Sherrill over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#5 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) set to 284

Also available in: Atom PDF