Project

General

Profile

Feature #22248

MondoDB enterprise support

Added by Christian Setzer almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

we want to use our mongodb enterpise subscriptions with foreman/katello. it would be beneficial to us if you could implement an option to make mongodb more autonomous.
reason was that we had on large repositories big perfomance impacts. community version in the supported centos7 version was just too slow to process the requests.

History

#1 Updated by Lukas Zapletal almost 2 years ago

  • Priority changed from Normal to Low
  • Category set to Foreman modules
  • Subject changed from mongodb enterprise support to MondoDB enterprise support
  • Project changed from Smart Proxy to Installer

Hello, are you asking for some installer options to be able to deploy against external MongoDB?

Anyway, the only component which use MongoDB is Pulp (https://pulpproject.org/) which is ditching MongoDB for PostgreSQL in version 3.x. This makes this RFE a lower priority, unless someone else wants to work on this.

Do you have any numbers that show improvements over CentOS 7 mongodb version?

#2 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Category changed from Foreman modules to Installer
  • Project changed from Installer to Katello

You can use the current installer with mongodb by setting mongodb::globals::manage_package: true in custom-hiera.yaml

#3 Updated by Justin Sherrill almost 2 years ago

  • Legacy Backlogs Release (now unused) set to 114

#4 Updated by Christian Setzer almost 2 years ago

talked to pulp-dev and we can close this. makes no sense since there will be no mongodb in the future.

#5 Updated by Michael Moll almost 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF