Project

General

Profile

Bug #22269

Operating system templates are ordered inconsistently in UI.

Added by Daniel Lobato Garcia over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
TFTP
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1531674

Description of problem:

If you navigate to "Hosts" -> "Operating Systems" -> specific-OS -> "Templates" tab for two different Operating Systems, the list of template types can be ordered differently. This makes for side-by-side comparison awkwardness.

How reproducible:

Steps to Reproduce:
1. navigate to "Hosts" -> "Operating Systems" -> specific-OS -> "Templates" tab for two different Operating Systems and compare the order.

Actual results:

Example from customer and local reproducer...
"Red Hat 7.3" template order....
Provisioning template
PXELinux template
Finish template
iPXE template
User data template
Discovery Kexec template
Boot disk embedded template

"Red Hat 6.8" template order ....
PXELinux template
iPXE template
Provisioning template
Finish template
User data template
Discovery Kexec template
Boot disk embedded template

Expected results:

Consistency in the order of template types - Maybe alphabetical (excepting when types are missing due to not being applicable)


Related issues

Related to Foreman - Bug #28737: When creating a new OS, I can not assign provisioning templatesClosed

Associated revisions

Revision 257d7701 (diff)
Added by yifat makias 7 months ago

Fixes #22269 - Added consistent order to os templates

History

#1 Updated by Daniel Lobato Garcia over 2 years ago

  • Subject changed from Operating system templates are ordered inconsistently in UI. to Operating system templates are ordered inconsistently in UI.

#2 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5337 added

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from Ready For Testing to New
  • Pull request deleted (https://github.com/theforeman/foreman/pull/5337)

#4 Updated by yifat makias 9 months ago

  • Assignee set to yifat makias
  • Status changed from New to Assigned

#5 Updated by The Foreman Bot 9 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7031 added

#6 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.0.0 added

#7 Updated by yifat makias 7 months ago

  • Status changed from Ready For Testing to Closed

#8 Updated by Marek Hulán 5 months ago

  • Related to Bug #28737: When creating a new OS, I can not assign provisioning templates added

Also available in: Atom PDF