Project

General

Profile

Bug #22330

New provisioned machines show a warning "reboot required". Solved by executing "katello-tracer-upload"

Added by Pablo Escobar almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Provisioning
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Hi,

We are running foreman 1.16 and katello 3.5.0 and we are hitting the same issue as described here
http://projects.theforeman.org/issues/19976

all new machines already provisioning asking to reboot

Status Error
Configuration No changes
Errata All errata applied
Subscription Fully entitled
Traces Reboot required

We noticed that the problem is solved if you manually execute "katello-tracer-upload" or "yum install XXX" in the machine after the first boot.

Trying to workaround the issue we added this at the end of our provisioning template but it didn't solve the problem.

<% if @provisioning_type == nil || @provisioning_type == 'host' -%>
# Inform the build system that we are done.
echo "Informing Foreman that we are built" 
wget -q -O /dev/null --no-check-certificate <%= foreman_url('built') %>
<% end -%>
# if this host has the katello client installed we 
# execute katello-tracer-upload so it's not in error
# status after the first boot
<% if @host.params['kt_activation_keys'] %>
echo "executing katello-tracer-upload" 
/usr/sbin/katello-tracer-upload
<% end -%>
) 2>&1 | tee /root/install.post.log
exit 0

This is what we get in production.log when the machine is provisioned

2018-01-19 13:07:59 28bd6d73 [app] [I]   Parameters: {"traces"=>{"kernel"=>{"type"=>"static", "helper"=>"You will have to reboot your computer"}, "systemd"=>{"type"=>"static", "helper"=>"You will have to reboot your computer"}, "anaconda-shell@hvc0"=>{"type"=>"daemon", "helper"=>"systemctl restart anaconda-shell@hvc0"}, "chronyd"=>{"type"=>"daemon", "helper"=>"systemctl restart chronyd"}, "lvm2-lvmetad"=>{"type"=>"daemon", "helper"=>"systemctl restart lvm2-lvmetad"}, "systemd-udevd"=>{"type"=>"daemon", "helper"=>"systemctl restart systemd-udevd"}, "dbus"=>{"type"=>"static", "helper"=>"You will have to reboot your computer"}, "anaconda-shell@hvc1"=>{"type"=>"daemon", "helper"=>"systemctl restart anaconda-shell@hvc1"}, "polkit"=>{"type"=>"daemon", "helper"=>"systemctl restart polkit"}, "systemd-logind"=>{"type"=>"daemon", "helper"=>"systemctl restart systemd-logind"}, "systemd-journald"=>{"type"=>"daemon", "helper"=>"systemctl restart systemd-journald"}, "rsyslog"=>{"type"=>"daemon", "helper"=>"systemctl restart rsyslog"}, "anaconda"=>{"type"=>"session", "helper"=>"You will have to log out & log in again"}, "multipathd"=>{"type"=>"daemon", "helper"=>"systemctl restart multipathd"}, "NetworkManager"=>{"type"=>"daemon", "helper"=>"systemctl restart NetworkManager"}}, "id"=>"9fe4fb4c-6ee1-464e-9af8-abeca962f19a"}

These are the rpms installed in the privisioned machine

katello-host-tools-fact-plugin-3.1.0-1.el7.noarch
katello-host-tools-3.1.0-1.el7.noarch
katello-ca-consumer-katello-dmz.scicore-dmz.lan-1.0-1.noarch
katello-agent-3.1.0-1.el7.noarch

by now the only workaround is to manually execute "katello-tracer-upload" in the provisioned machine after the first boot

Associated revisions

Revision dda4dc30 (diff)
Added by Sean O'Keeffe over 1 year ago

Fixes #22330 - Always run cron after reboot

If this runs before the network is up, it will not work.
Adding a sleep as a slightly dirty hack.

Revision dda4dc30 (diff)
Added by Sean O'Keeffe over 1 year ago

Fixes #22330 - Always run cron after reboot

If this runs before the network is up, it will not work.
Adding a sleep as a slightly dirty hack.

History

#1 Updated by Sean O'Keeffe almost 2 years ago

Interesting because there is already a cron that should send a new report after a reboot https://github.com/Katello/katello-host-tools/blob/master/extra/katello-agent-send.cron. Do you have any logs to show this did or didn't run or if there was/is a problem with it running?

#2 Updated by Andrew Kofink almost 2 years ago

  • Legacy Backlogs Release (now unused) deleted (250)

#3 Updated by Justin Sherrill almost 2 years ago

  • Legacy Backlogs Release (now unused) set to 284
  • Status changed from New to Needs design

#4 Updated by Pablo Escobar almost 2 years ago

Thanks for the pointer. I have double checked that the cron file is installed in `/etc/cron.d/katello-host-tools`

That's really weird. I cannot explain it. I will try to do some more testing and report back if I figure out what's happening.

#5 Updated by Pablo Escobar over 1 year ago

after some more testing now the machines stay in "reboot required" even if we execute the "katello-tracer-upload" or even if we reboot the machine.

If I go to hosts >> content hosts >> traces and I apply the filter "helper == "You will have to reboot your computer"" I get this and I don't know how to fix it

Application Type Helper
dbus static You will have to reboot your computer
systemd static You will have to reboot your computer

Any suggestion about how to debug this problem?

#6 Updated by Sean O'Keeffe over 1 year ago

  • Pull request https://github.com/Katello/katello-host-tools/pull/50 added

#7 Updated by Anonymous over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Needs design to Closed

Also available in: Atom PDF