Project

General

Profile

Support #22429

Jobs page fails to open with error message "PG::UndefinedTable: ERROR: relation "job_invocations" does not exist"

Added by Ben Howell almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Foreman
Target version:
-
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

"Oops, we're sorry but something went wrong PG::UndefinedTable: ERROR: relation "job_invocations" does not exist LINE 1: SELECT "job_invocations".* FROM "job_invocations" ORDER BY... ^ : SELECT "job_invocations".* FROM "job_invocations" ORDER BY job_invocations.id DESC LIMIT 50 OFFSET 0"

This is after an upgrade to foreman 1.16.0. I think I deleted the schema from the database because of the "PG::DuplicateColumn: ERROR: column "version" of relation "dynflow_schema_info" already exists" problem. I resolved that by downgrading pg and sequel, but db:migrate and db:seed don't seem to re-create the job_invocations table.

Is there a foreman-rake command that can fix this? Is it possible to rebuild my database without destroying all of the info that's currently in it?


Related issues

Is duplicate of Packaging - Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environmentClosed2017-06-19

History

#1 Updated by Anonymous almost 4 years ago

  • Priority changed from High to Normal
  • Category set to Foreman
  • Project changed from Foreman to Foreman Remote Execution

#2 Updated by Anonymous almost 4 years ago

  • Related to Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environment added

#3 Updated by Anonymous over 3 years ago

  • Status changed from New to Closed

#4 Updated by Anonymous over 3 years ago

  • Related to deleted (Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environment)

#5 Updated by Anonymous over 3 years ago

  • Is duplicate of Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environment added

Also available in: Atom PDF