Project

General

Profile

Bug #22445

Content view sync with puppet repos fails with undefined method content_type for nil

Added by Andrew Kofink over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

During task planning phase Actions::Katello::CapsuleContent::Sync failed with undefined method `content_type' for nil:NilClass (NoMethodError)

Actions::Katello::CapsuleContent::Sync

Input:

---
smart_proxy:
id: 2
name: cap.example.com
services_checked:
- pulp
- pulp_auth

undefined method `content_type' for nil:NilClass (NoMethodError)
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:65:in `block (3 levels) in sync_repos_to_capsule'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `switch_flow'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/action.rb:369:in `sequence'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:54:in `block (2 levels) in sync_repos_to_capsule'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:53:in `each'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:53:in `block in sync_repos_to_capsule'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `switch_flow'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/action.rb:364:in `concurrence'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:52:in `sync_repos_to_capsule'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:46:in `block in plan'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/execution_plan.rb:316:in `switch_flow'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/action.rb:369:in `sequence'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.161/app/lib/actions/katello/capsule_content/sync.rb:41:in `plan'
/opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.13.6/lib/dynflow/action.rb:461:in `block (3 levels) in execute_plan'


Related issues

Is duplicate of Katello - Bug #20540: Duplicate Unit Names in Smart-Proxy Sync after 3.4.4 upgradeClosed2017-08-09

History

#1 Updated by Andrew Kofink over 4 years ago

  • Is duplicate of Bug #20540: Duplicate Unit Names in Smart-Proxy Sync after 3.4.4 upgrade added

#2 Updated by Andrew Kofink over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from New to Duplicate

Also available in: Atom PDF