Project

General

Profile

Bug #22550

Do not show 6.2.z upgrade option if Satellite is already in latest 6.2.z

Added by Swapnil Abnave almost 3 years ago.

Status:
New
Priority:
High
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1543920

Description of problem:
Do not show 6.2.z upgrade option if Satellite is already in latest 6.2.z

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.1.3-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. The current 6.2 version in prod is 6.2.14. I have my Satellite in this version. When I run the upgrade tooling check, it still gives me an option to move to latest z-stream

  1. rpm -q satellite
    satellite-6.2.14-4.0.el7sat.noarch
  1. foreman-maintain upgrade check
    --target-version not specified
    Possible target versions are:
    6.2.z
    6.3

Actual results:
As explained above

Expected results:
Do not show 6.2.z stream option if Satellite is already in latest 6.2.z

Additional info:

Also available in: Atom PDF