Project

General

Profile

Bug #2261

Test run issues with Jenkins under Ruby 1.9

Added by Dominic Cleal over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Similar to #2256, but for the proxy the following is needed:

  • Jenkins rake tasks need to support minitest for Ruby 1.9
  • Fix settings loading under 1.9 (PLATFORM constant)
  • Specify rdoc and minitest in test bundler group to fix old versions on Ruby 1.9.2
  • util which tests should test for 1.9 and not 1.9.3 specifically

Associated revisions

Revision 0acfdc97 (diff)
Added by Dominic Cleal over 7 years ago

fixes #2261 - fixes for CI testing under Ruby 1.9

Support minitest in Jenkins rake tasks, add rdoc and minitest deps due to
old 1.9.2 versions. Fix PLATFORM under 1.9, fix 1.9.3 specific test.

History

#1 Updated by Dominic Cleal over 7 years ago

  • Status changed from New to Ready For Testing

#2 Updated by Ohad Levy over 7 years ago

  • Target version set to 26

#3 Updated by Dominic Cleal over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 7 years ago

  • Target version changed from 26 to 1.2.0

#5 Updated by Greg Sutcliffe over 2 years ago

  • Target version deleted (1.2.0)

Also available in: Atom PDF