Project

General

Profile

Bug #22638

Content view repository List/Remove page is the same as Add page

Added by Alexander Murashkin 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

After update to katello-3.5.1-1.el7 one of content views shows incorrect list of YUM repositories. Specifically, if I go to

Content->Content Views->Fedora 27 Server->Yum Content->Repositories->List/Remove page

it does not show the correct list of included repositories, it shows instead the same list as Add page (not included repositories). Screenshots of both pages attached.

Hammer prints a list of repositories that seems OK (attached). Postgresql tables look also OK.

Production log (attached) for List/Remove and Add pages contains different browser URLs, as expected, but the same API requests .

List/Remove - https://sat01.example.com/content_views/2/repositories/yum?page=1&per_page=100
GET "/katello/api/v2/repositories?available_for=content_view&content_type=yum&content_view_id=2&full_result=true&library=true&organization_id=1&page=1&paged=true&per_page=100&search="

Add - https://sat01.example.com/content_views/2/repositories/yum/available?page=1&per_page=100
GET "/katello/api/v2/repositories?available_for=content_view&content_type=yum&content_view_id=2&full_result=true&library=true&organization_id=1&page=1&paged=true&per_page=100&search="

Note that other content views are shown correctly. For example, content_view_id 4, List/Remove and Add API request

GET "/katello/api/v2/repositories?content_type=yum&content_view_id=4&full_result=true&organization_id=1&page=1&paged=true&per_page=100&search="
GET "/katello/api/v2/repositories?available_for=content_view&content_type=yum&content_view_id=4&full_result=true&library=true&organization_id=1&page=1&paged=true&per_page=100&search="

hammer_output.txt hammer_output.txt 37 KB hammer output for content view and repos Alexander Murashkin, 02/21/2018 04:14 AM
Repository_Selection_List_Remove.png View Repository_Selection_List_Remove.png 236 KB screenshot of List/Remove page Alexander Murashkin, 02/21/2018 04:28 AM
Repository_Selection_Add.png View Repository_Selection_Add.png 233 KB screenshot of Add page Alexander Murashkin, 02/21/2018 04:28 AM
recently_installed_rpms.txt recently_installed_rpms.txt 6.94 KB recently installed RPMs Alexander Murashkin, 02/21/2018 04:33 AM
production_log_list_remove.txt production_log_list_remove.txt 444 KB log of List/Remove page Alexander Murashkin, 02/21/2018 05:02 AM
production_log_add.txt production_log_add.txt 445 KB log of Add page Alexander Murashkin, 02/21/2018 05:02 AM
Repository selection list remove Repository selection add

History

#1 Updated by hack apps 9 months ago

  • Subject changed from Content view repository List/Remove page is the same as Add page to How to use Game Killer APK Download v5.0 - Latest Version

GO AWAY SPAM

#2 Updated by Marek Hulán 9 months ago

someone please delete the spam, I don't have delete permissions here

#3 Updated by Alexander Murashkin 9 months ago

  • Subject changed from How to use Game Killer APK Download v5.0 - Latest Version to Content view repository List/Remove page is the same as Add page

#4 Updated by Justin Sherrill 9 months ago

  • Legacy Backlogs Release (now unused) set to 339
  • Target version set to 245
  • Priority changed from Normal to Urgent
  • Assignee set to Andrew Kofink

#5 Updated by Andrew Kofink 9 months ago

Is this only happening for one of your content views? I just tried it with a small sample of data on a fresh 3.5.1 install, and it seems to work fine. Are you getting any javascript errors in your web console?

#6 Updated by Alexander Murashkin 9 months ago

Andrew Kofink wrote:

Is this only happening for one of your content views?

It was just one content view. All other content views were OK.

I just tried it with a small sample of data on a fresh 3.5.1 install, and it seems to work fine. Are you getting any javascript errors in your web console?

Sorry, I cannot reproduce the problem anymore. Yesterday it was happening all the day. Today all content views look OK.

I restarted httpd today. But I also restarted it few times yesterday.

I did not see any javascript errors in Firefox (though I was not running web console).

#7 Updated by Andrew Kofink 9 months ago

  • Legacy Backlogs Release (now unused) changed from 339 to 166
  • Status changed from New to Closed

Perhaps this was some cache in your browser or something? Regardless, I'm going to close it for now. Please reopen if you see it again, and please attach some javascript and/or server logs if you can get any.

Also available in: Atom PDF