Project

General

Profile

Feature #22686

foreman-maintain should run subscription-manager refresh before enabling repos for sat 6.3

Added by Kavita Gaikwad almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
In some situations, the new repos are not yet known on the client, and f-maintain aborts with

Error: 'rhel-7-server-satellite-6.3-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories.

If it would run "sub-man refresh" before, this would not happen.

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.1.3-1.el7sat.noarch

Associated revisions

Revision a7087895 (diff)
Added by Kavita Gaikwad almost 4 years ago

Fixes #22686 - subscription-manager refresh to get new repos

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/148 added

#2 Updated by Kavita Gaikwad almost 4 years ago

  • Tracker changed from Bug to Feature

#3 Updated by Kavita Gaikwad almost 4 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

#4 Updated by Ivan Necas over 3 years ago

  • Legacy Backlogs Release (now unused) set to 348

Also available in: Atom PDF