Project

General

Profile

Bug #22691

Forklift fails to install Katello 3.6 because of Puppet module thias-squid not supporting Puppet 5

Added by Dirk Götz almost 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When I try to install a new box with katello 3.6 it fails with the following error caused by Puppet module thias-squid not supporting Puppet 5:

fatal: [centos7-katello-3.6]: FAILED! => {
    "changed": true, 
    "cmd": "foreman-installer -v --scenario \"katello\"  --disable-system-checks --foreman-admin-password changeme", 
    "delta": "0:00:04.143123", 
    "end": "2018-02-26 05:47:11.850356", 
    "failed": true, 
    "rc": 30, 
    "start": "2018-02-26 05:47:07.707233" 
}

STDOUT:

Puppet 5.4.0 does not meet requirements for thias-squid3 (>=2.7.20 <5.0.0)
Cannot continue due to incompatible version of Puppet. Use --skip-puppet-version-check to disable this check.

MSG:

non-zero return code

Running the foreman-installer command with --skip-puppet-version-check after vagrant ssh works.

I hope Katello is the right project for this issue, if you think it should be addressed at Kafo or Forklift please move it or close here and I will reopen on the other project.


Related issues

Has duplicate Installer - Bug #22746: Squid module marked as incompatible with Puppet 5Closed

History

#1 Updated by Andrew Kofink almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 284
  • Assignee set to Zach Huntington-Meath

#2 Updated by Zach Huntington-Meath almost 3 years ago

  • Has duplicate Bug #22746: Squid module marked as incompatible with Puppet 5 added

#3 Updated by John Mitsch almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 284 to 352

#4 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Triaged set to No
  • Status changed from New to Closed

We've switched our implementation to one that is compatible.

#5 Updated by Christine Fouant almost 2 years ago

  • Triaged changed from No to Yes

Also available in: Atom PDF