Project

General

Profile

Bug #22698

clearing search filter does not clear search filter

Added by Ohad Levy 6 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Search
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

steps to reproduce

1. go to a page with search, set some filter condition and click search
2. click on the 'x' button to clear the search filter
3. click on search again, and note that the page retain its current search condition.

Associated revisions

Revision 2ce888d2 (diff)
Added by boaz shust 3 months ago

Fixes #22698 - clear the search filter

clearing the search filter does not take place when submitting

Signed-off-by: Boaz Shuster <>

History

#1 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5434 added

#2 Updated by Ondřej Pražák 4 months ago

  • Legacy Backlogs Release (now unused) set to 297

#3 Updated by Marek Hulán 4 months ago

btw is this a 1.17 regression? could you add related issue if you have the introducing issue?

#4 Updated by Marek Hulán 4 months ago

I think it has not been working long before 1.17, while it might be small enough fix for cherry-picking, I don't think we'd do 1.17.1 only because of this. The introducing issue was not provided. Of course leaving the decision on the owner of the release.

#5 Updated by Tomer Brisker 3 months ago

  • Legacy Backlogs Release (now unused) changed from 297 to 360

Pushing out to 1.17.2, this won't be fixed in time for 1.17.1.

#6 Updated by Tomer Brisker 3 months ago

  • Legacy Backlogs Release (now unused) changed from 360 to 330

pushing out to 1.18.0 for now

#7 Updated by The Foreman Bot 3 months ago

  • Assignee set to Tomer Brisker
  • Pull request https://github.com/theforeman/foreman/pull/5601 added

#8 Updated by boaz shust 3 months ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF