Project

General

Profile

Bug #22719

Katello 3.5.1 - Maximum depth exceeded on katello_event_queue

Added by Philipp Mueller 6 months ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Brad
Fixed in Releases:
Found in Releases:

Description

Hi,

qpidd constantly crashes when trying to work with hammer shell or katello webfrontend.

Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)
Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)

please help

kind regards,
Philipp

History

#1 Updated by Andrew Kofink 6 months ago

  • Legacy Backlogs Release (now unused) set to 339
  • Target version set to 160

#2 Updated by Andrew Kofink 5 months ago

  • Legacy Backlogs Release (now unused) changed from 339 to 351

#3 Updated by Kristoffer Tångfelt 5 months ago

I'm also seeing this error in an instance. except with the katello hosts fqdn + :event instead of "Katello_event_queue"

Philipp Mueller wrote:

Hi,

qpidd constantly crashes when trying to work with hammer shell or katello webfrontend.

Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)
Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)

please help

kind regards,
Philipp

#4 Updated by Kristoffer Tångfelt 5 months ago

Disregard my comment. it was related to another issue, a remnant of the gutterball removal left a <FQDN>:event queue.

Kristoffer Tångfelt wrote:

I'm also seeing this error in an instance. except with the katello hosts fqdn + :event instead of "Katello_event_queue"

Philipp Mueller wrote:

Hi,

qpidd constantly crashes when trying to work with hammer shell or katello webfrontend.

Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)
Feb 28 11:26:58 amu642.rsint.net qpidd28436: 2018-02-28 11:26:58 [Broker] error Execution exception: resource-limit-exceeded: Maximum depth exceeded on katello_event_queue: current=[count: 4142, size: 104857155], max=[size: 104857600] (/builddir/build/BUILD/qpid-cpp-1.36.0/src/qpid/broker/Queue.cpp:1662)

please help

kind regards,
Philipp

Also available in: Atom PDF