Project

General

Profile

Bug #22725

Katello-certs-check need to check and make sure "new line" present at the end of the certificate

Added by Chris Roberts over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

cloned from bz:

Description of problem:

When attempting to install katello-ca-consumer package on a client system registered to a Red Hat Satellite 6.2, rpm installation fails with below error message:

[root@satellite ~]# rpm -Uvh http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm
Retrieving http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm
Preparing... ################################# [100%]
Updating / installing...
1:katello-ca-consumer-satellite.example################################# [100%]
/usr/bin/katello-rhsm-consumer: line 260: warning: here-document at line 102 delimited by end-of-file (wanted `EOM')
warning: %post(katello-ca-consumer-satellite.example.com-1.0-1.noarch) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):

Red Hat Satellite 6

How reproducible:

Install custom certificate which has no NewLine at the End Of File

Steps to Reproduce:

- Create custom certificate to configure satellite with them
- Make sure custom certificate has not Newline at the end of file
- Run katello-certs-check to verify certificate
- Install Custom certificate to Satellite
- Register client machine using new "katello-ca-consumer" and find the mentioned error.

Actual results:

Katello-certs-check or a satellite-installer has not detected the End Of Line issue.

Expected results:

Katello-certs-check should have a mechanism to detected it since we are using it to verify the certificate against CA before installing the custom certificate.

Additional info:
find the kcs and cases linked to it for reference,

Installing katello-ca-consumer-latest.noarch.rpm from Red Hat Satellite 6 fails with ' warning: here-document at line 102 delimited by end-of-file (wanted `EOM')' error
https://access.redhat.com/solutions/2619071

Associated revisions

Revision f960c6ee (diff)
Added by Chris Roberts about 3 years ago

Fixes #22725 - Add newline to CA to prevent EOM error on registration.

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/597 added

#2 Updated by Chris Roberts over 3 years ago

  • Assignee deleted (Chris Roberts)
  • Status changed from Ready For Testing to New
  • Pull request deleted (https://github.com/Katello/katello-installer/pull/597)

#3 Updated by The Foreman Bot about 3 years ago

  • Assignee set to Chris Roberts
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-certs/pull/198 added

#4 Updated by Chris Roberts about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF