Project

General

Profile

Bug #22746

Squid module marked as incompatible with Puppet 5

Added by Ewoud Kohl van Wijngaarden over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
External (Puppet Labs) modules
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

This causes the installer to fail even though the module works.


Related issues

Is duplicate of Katello - Bug #22691: Forklift fails to install Katello 3.6 because of Puppet module thias-squid not supporting Puppet 5Closed
Has duplicate Katello - Bug #22924: Puppet 5.x not supported by foreman-installer (thias-squid3)Duplicate2018-03-16

Associated revisions

Revision b6f6141b (diff)
Added by Ewoud Kohl van Wijngaarden over 1 year ago

Refs #22746 - Use a forked version of thias-squid3

Revision 5361748a (diff)
Added by Ewoud Kohl van Wijngaarden 9 months ago

Fixes #22746 - Complete the switch to voxpupuli-squid

We no longer need to ship our own fork now that puppet-pulp has
switched.

History

#1 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

This affects 3.6 and nightly since those include kafo 2.1.0.

#2 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

  • Category set to Installer
  • Project changed from Installer to Katello

#3 Updated by Zach Huntington-Meath over 1 year ago

  • Legacy Backlogs Release (now unused) set to 284

#4 Updated by Zach Huntington-Meath over 1 year ago

  • Pull request https://github.com/Katello/katello-installer/pull/598 added

#5 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Zach Huntington-Meath
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/596 added

#6 Updated by Zach Huntington-Meath over 1 year ago

  • Is duplicate of Bug #22691: Forklift fails to install Katello 3.6 because of Puppet module thias-squid not supporting Puppet 5 added

#7 Updated by Michael Moll over 1 year ago

  • Has duplicate Bug #22924: Puppet 5.x not supported by foreman-installer (thias-squid3) added

#8 Updated by John Mitsch over 1 year ago

  • Legacy Backlogs Release (now unused) changed from 284 to 352

#9 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

  • Triaged set to Yes
  • Target version changed from Katello 3.6.1 to Katello 3.9.0
  • Assignee deleted (Zach Huntington-Meath)
  • Status changed from Ready For Testing to New
  • Pull request deleted (https://github.com/Katello/katello-installer/pull/598, https://github.com/Katello/katello-installer/pull/596)

#10 Updated by Zach Huntington-Meath about 1 year ago

  • Target version changed from Katello 3.9.0 to Katello 3.11.0

#11 Updated by Jonathon Turel 10 months ago

  • Target version changed from Katello 3.11.0 to Katello Backlog

Ewoud - is this still a thing?

#12 Updated by Ewoud Kohl van Wijngaarden 9 months ago

  • Target version changed from Katello Backlog to 1.22.0
  • Assignee set to Ewoud Kohl van Wijngaarden
  • Category changed from Installer to External (Puppet Labs) modules
  • Project changed from Katello to Installer
  • Fixed in Releases 1.22.0 added

#13 Updated by Ewoud Kohl van Wijngaarden 9 months ago

  • Status changed from New to Closed

We've switched our implementation to one that is compatible.

#14 Updated by The Foreman Bot 9 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/319 added

Also available in: Atom PDF