Project

General

Profile

Bug #22795

ISE when changing Organization setting of Smart Proxy when Lifecycle Environment is set

Added by Lukáš Hellebrandt over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

1) Have a Foreman with Katello, with entities created by installation only
2) Register a Smart Proxy to Foreman
3) In WebUI, go to Infrastructure -> Smart Proxies
4) Select the Proxy, edit it
5) Set LE to Library, submit
6) Edit again, set/unset Organization, submit
=>
1) WebUI warning: "undefined method `enabled' for []:Array"
2) Traceback in /var/log/foreman/production.log (attached)

Reproduced on nightly as of 2018-03-06

traceback.txt traceback.txt 18.6 KB production.log Lukáš Hellebrandt, 03/06/2018 03:14 PM

Related issues

Is duplicate of Katello - Bug #23190: replace .uniq with .distinct in content viewClosed2018-04-09

History

#1 Updated by John Mitsch over 3 years ago

  • Legacy Backlogs Release (now unused) set to 338

#2 Updated by Thomas McKay about 3 years ago

  • Is duplicate of Bug #23190: replace .uniq with .distinct in content view added

#3 Updated by Thomas McKay about 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF