Project

General

Profile

Bug #22834

JS Error: s.included.ids is undefined - on choosing REX on host collection ERRATA dialog

Added by Thomas McKay over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1553017

Description of problem:
Similar to https://bugzilla.redhat.com/show_bug.cgi?id=1532605 but it was fixed only for the "Package Installation, Removal, and Update" action. Need to fix the same for the 'Errata Installation' action.

Version-Release number of selected component (if applicable):
6.3.0

How reproducible:
100%

Steps to Reproduce:
1. define a host collection
2. navigate to host collection and choose e.g. "Errata Installation" action
3. [open up the browser console to spot the error,] from any dropdown, try to choose remote execution or rex (customize first)

Actual results:
js traceback - s.included.ids is undefined

Expected results:
no errors, dialog and rex just works

Additional info:

it looks like we need to change `/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.5.58/engines/bastion_katello/app/assets/javascripts/bastion_katello/content-hosts/bulk/content-hosts-bulk-errata-modal.controller.js` like this:

Replace

formData.hostIds = selectedHosts.included.ids.join(',');

with

if (selectedHosts.included.ids) {
formData.hostIds = selectedHosts.included.ids.join(',');
}

Associated revisions

Revision 183ec4a0 (diff)
Added by Thomas McKay over 4 years ago

fixes #22834 - fix JS error on host collection bulk errata

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7231 added

#2 Updated by Andrew Kofink over 4 years ago

  • Legacy Backlogs Release (now unused) set to 284
  • Subject changed from JS Error: s.included.ids is undefined - on choosing REX on host collection ERRATA dialog to JS Error: s.included.ids is undefined - on choosing REX on host collection ERRATA dialog

#3 Updated by Thomas McKay over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF