Bug #22940

foreman-installer does not create /usr/share/foreman/.postgresql/root.crt

Added by Ales Dujicek 4 months ago. Updated 5 days ago.

Status:Closed
Priority:Normal
Assignee:Ewoud Kohl van Wijngaarden
Category:Foreman modules
Target version:1.18.0
Difficulty: Team Backlog:
Triaged:No Fixed in Releases:1.18.0
Bugzilla link:1592681 Found in Releases:Foreman - Nightly
Pull request:https://github.com/theforeman/puppet-foreman/pull/650

Description

foreman-installer does not create /usr/share/foreman/.postgresql/root.crt when --foreman-db-manage false is set

how to reproduce:
  1. foreman-installer --scenario katello --foreman-db-manage false --foreman-db-host remote-db-host.redhat.com --foreman-db-root-cert /usr/share/foreman/root.crt
    [ WARN 2018-03-19T10:24:21 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: ActiveRecord::NoDatabaseError: root certificate file "/usr/share/foreman/.postgresql/root.crt" does not exist
  2. ls /usr/share/foreman/.postgresql/root.crt
    ls: cannot access /usr/share/foreman/.postgresql/root.crt: No such file or directory

version
foreman-installer-1.18.0-0.develop.201803160331giteb46741.el7.noarch


Related issues

Related to Installer - Bug #20079: Foreman does not verify CA on postgres DB connections wit... Closed 06/21/2017

Associated revisions

Revision b9371650
Added by Ewoud Kohl van Wijngaarden 14 days ago

Fixes #22940 - Ensure the PG root cert is installed

When a remote database is used the postgres server is not managed. This
meant that the certificate was not placed. It's moved to the config
since it's a client config that always needs to happen.

History

#1 Updated by Ales Dujicek 4 months ago

  • Related to Bug #20079: Foreman does not verify CA on postgres DB connections with SSL added

#2 Updated by Ales Dujicek 28 days ago

  • Bugzilla link set to 1592681

#3 Updated by Ales Dujicek 28 days ago

  • Subject changed from foreman-installer does create /usr/share/foreman/.postgresql/root.crt to foreman-installer does not create /usr/share/foreman/.postgresql/root.crt

#4 Updated by Ivan Necas 28 days ago

  • Category set to Foreman modules
  • Project changed from Foreman to Installer

#5 Updated by The Foreman Bot 14 days ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman/pull/650 added

#6 Updated by Ewoud Kohl van Wijngaarden 14 days ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#7 Updated by Ewoud Kohl van Wijngaarden 5 days ago

  • Triaged set to No
  • Target version set to 1.18.0

#8 Updated by Ewoud Kohl van Wijngaarden 5 days ago

  • Fixed in Releases 1.18.0 added

Also available in: Atom PDF