Project

General

Profile

Bug #22943

cpdb incorrect password when upgrading to Katello 3.5 with CP 2.1.14

Added by Andrew Kofink about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

From https://community.theforeman.org/t/katello-upgrade-from-3-4-to-3-5-fails-because-of-candlepin-version-candlepin-2-1-14-1-el7/8617/1:

I had issues while upgrading from Katello 3.4 to 3.5, the issue because of candlepin version 2.1.14.-1. The cpdb did not accept the password even tried manually with the password there in /etc/candlepin/candlepin/conf.

So I had to downgrade the candlepin rpm with 2.0.40-1(candlepin-2.0.40-1 and candlepin-selinux-2.0.40-1) then the upgrade works fine and all looks good.

I don’t know who else had tried to upgrade or installed 3.5 wtih candlepin 2.1.14-1 version but this should be a bug in the upgrade.

History

#1 Updated by Andrew Kofink about 4 years ago

  • Legacy Backlogs Release (now unused) changed from 339 to 166
  • Status changed from New to Closed

This is fixed with the recent upgrade to Candlepin 2.1.14-1

Also available in: Atom PDF