Project

General

Profile

Bug #2312

Foreman fails to update domain name

Added by Jaroslav Henner over 6 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Smart proxies
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Using some MS DNS server, trying to update domain name of a Libvirt VM, Foreman fails to do so. It asks about overwriting the PTR, but it doesn

History

#1 Updated by Jaroslav Henner over 6 years ago

Using some MS DNS server, trying to update domain name of a Libvirt VM, Foreman fails to do so. It asks about overwriting the PTR, but it doesn't overwrite the PTR, nor it changes the A records accordingly.

Workaround is to delete the PTR by hand, then updating the name.

Note it also causes a schizophrenic behaviour: `https://puppet.rhos/hosts/bar.xxx` in url, but `foo.xxx` as VM name.

#2 Updated by Jaroslav Henner over 6 years ago

See #1860

#3 Updated by Anonymous about 6 years ago

Note that each record in AD DNS has separate ACL. The problem can be caused by ACL preventing the update.

#4 Updated by Michael Moll about 2 years ago

  • Status changed from New to Resolved

a lot has changed since then...

Also available in: Atom PDF