Project

General

Profile

Bug #23153

Installer sets listening address of qpid_router_agent to IPv4 0.0.0.0

Added by Gerald Vogt about 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I have noticed on a new installation of foreman/katello on CentOS 7 that connections to the qpid-router on port 5647 don't work with error "connection refused". The reason is that the host has an IPv6 and IPv4 address in DNS. Due to that the connection is preferably tried done with IPv6.

However, the default configuration sets "qpid_router_agent_addr: 0.0.0.0" which makes it into /etc/qpid-dispatch/qdrouterd.conf. This means the qdrouterd listens only on the IPv4 address and not on IPv6. Thus, if a client connects and only tries with IPv6 it gets a connection refused and gives up.

I have manually reconfigure the listener in qdrouterd.conf

listener {
#    host: 0.0.0.0
    port: 5647
    sasl-mechanisms: ANONYMOUS
    ssl-profile: server
}

and restarted the daemon. Now it listens to IPv4 and IPv6 and connections work just fine.

Thus, I guess the default for the option

--foreman-proxy-content-qpid-router-agent-addr  Listener address for goferd agents (current: "0.0.0.0")

should not be 0.0.0.0 but emtpy instead to omit the host option from the listener configuration.


Related issues

Is duplicate of Katello - Bug #12386: qdrouterd should listen to ipv6Closed

History

#1 Updated by Stephen Benjamin about 2 years ago

  • Is duplicate of Bug #12386: qdrouterd should listen to ipv6 added

#2 Updated by Stephen Benjamin about 2 years ago

  • Status changed from New to Duplicate

This will be fixed when #12386 is resolved.

#3 Updated by Justin Sherrill about 2 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF