Project

General

Profile

Bug #23159

smart-proxy page with pulp throws 404 error

Added by Thomas McKay about 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Forklift 'playbooks/devel.yml' and 'playbooks/foreman_proxy_content_dev.yml'
Single docker repo in CV in LCE

2018-04-07T12:59:24 [I|kat|7ae80] RestClient.get "https://registry.example.com:9090/pulp/api/v2/repositories/", "Accept"=>"*/*", "Accept-Encoding"=>"gzip, deflate", "User-Agent"=>"rest-client/2.0.2 (linux-gnu x86_64) ruby/2.4.1p111", "accept"=>"application/json", "content_type"=>"application/json" 
 | \n# => 404 NotFound | application/json 27 bytes
 | 
2018-04-07T12:59:24 [I|app|7ae80]   Rendered /home/vagrant/code/katello/app/views/katello/api/v2/capsule_content/sync_status.json.rabl (1473.9ms)
2018-04-07T12:59:24 [E|app|7ae80] ActionView::Template::Error: 404 Not Found
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/abstract_response.rb:223:in `exception_with_response'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/abstract_response.rb:103:in `return!'
 | /home/vagrant/code/runcible/lib/runcible/base.rb:81:in `block in get_response'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/request.rb:807:in `process_result'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/request.rb:725:in `block in transmit'
 | /home/vagrant/.rvm/rubies/ruby-2.4.1/lib/ruby/2.4.0/net/http.rb:877:in `start'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/request.rb:715:in `transmit'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/request.rb:145:in `execute'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/request.rb:52:in `execute'
 | /home/vagrant/.rvm/gems/ruby-2.4.1/gems/rest-client-2.0.2/lib/restclient/resource.rb:51:in `get'
 | /home/vagrant/code/runcible/lib/runcible/base.rb:80:in `get_response'

Related issues

Is duplicate of Katello - Bug #23181: server using :9090 port for smart-proxy pulp callsClosed2018-04-09

History

#1 Updated by Thomas McKay about 4 years ago

Perhaps a second issue is warranted for this; I'll let component owners decide.

Running 'katello-service status' on capsule shows all healthy. In output, though:

Apr 07 14:25:16 registry.example.com smart-proxy[9345]: devel.example.com - - [07/Apr/2018:14:25:16 UTC] "GET /pulp/api/v2/repositories/ HTTP/1.1" 404 27
Apr 07 14:25:16 registry.example.com smart-proxy[9345]: - -> /pulp/api/v2/repositories/

#2 Updated by Thomas McKay about 4 years ago

I should also note that /var/lib/pulp/content dir was not created on capsule setup.

#3 Updated by Justin Sherrill about 4 years ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from New to Duplicate

#4 Updated by Justin Sherrill about 4 years ago

  • Is duplicate of Bug #23181: server using :9090 port for smart-proxy pulp calls added

Also available in: Atom PDF