Project

General

Profile

Bug #23299

Sequel::DatabaseError: PG::DuplicateColumn: ERROR: column "version" of relation "dynflow_schema_info" already exists

Added by Johannes Black over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Dynflow
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Just upgraded from 17 RC2 to 17.0

The problem still exists. I removed the complete database to make sure it's not in the database. Same result

For bug searching I only activated

1. [✓] Configure foreman
5. [✓] Configure puppet

with the default values.

Unfortunately this problem existed in RC1 and RC2, too. Source system is Debian Stretch AMD64. Foreman isn't usable for several months now so I am happy I haven't used it in production yet. ;-(

Do you need additional information or log files?

 INFO 2018-04-17T15:31:37 main]  /Stage[main]/Foreman::Database/Foreman_config_entry[db_pending_migration]: Scheduling refresh of Foreman::Rake[db:migrate]
[ INFO 2018-04-17T15:31:37 main]  /Stage[main]/Foreman::Database/Foreman_config_entry[db_pending_migration]: Evaluated in 8.25 seconds
[ INFO 2018-04-17T15:31:37 main]  Foreman::Rake[db:migrate]: Starting to evaluate the resource
[ INFO 2018-04-17T15:31:37 main]  Foreman::Rake[db:migrate]: Scheduling refresh of Exec[foreman-rake-db:migrate]
[ INFO 2018-04-17T15:31:37 main]  Foreman::Rake[db:migrate]: Evaluated in 0.00 seconds
[ INFO 2018-04-17T15:31:37 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Starting to evaluate the resource
[DEBUG 2018-04-17T15:31:37 main]  Exec[foreman-rake-db:migrate](provider=posix): Executing '/usr/sbin/foreman-rake db:migrate'
[DEBUG 2018-04-17T15:31:37 main]  Executing with uid=foreman: '/usr/sbin/foreman-rake db:migrate'
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: The PGconn, PGresult, and PGError constants are deprecated, and will be
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: removed as of version 1.0.
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns:
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: You should use PG::Connection, PG::Result, and PG::Error instead, respectively.
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns:
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: Called from /usr/share/foreman/vendor/ruby/2.3.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:258:in `load_dependency'
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: rake aborted!
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: Sequel::DatabaseError: PG::DuplicateColumn: ERROR:  column "version" of relation "dynflow_schema_info" already exists
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/vendor/ruby/2.3.0/gems/sequel-5.7.1/lib/sequel/adapters/postgres.rb:146:in `async_exec'
[ WARN 2018-04-17T15:31:45 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/vendor/ruby/2.3.0/gems/sequel-5.7.1/lib/sequel/adapters/postgres.rb:146:in `block in execute_query'


Related issues

Is duplicate of Packaging - Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environmentClosed2017-06-19

History

#1 Updated by Anonymous over 3 years ago

  • Is duplicate of Bug #20050: ruby-sequel-pg DEB pollutes Foreman ruby gem environment added

#2 Updated by Anonymous over 3 years ago

  • Legacy Backlogs Release (now unused) deleted (296)
  • Status changed from New to Duplicate
  • Category set to Dynflow
  • Project changed from Installer to foreman-tasks

Also available in: Atom PDF