Project

General

Profile

Bug #23371

Hammer throws "warning: constant ::Fixnum is deprecated" errors with all calls

Added by Lachlan Simpson over 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When I run hammer on the cli (discovered against `hammer repository synchronize --id 5 --source-url http://fedora.melbourneitmirror.net/epel/7/x86_64/`, can replicate with `hammer --help`) I see this output before command executes:

/opt/theforeman/tfm/root/usr/share/gems/gems/logging-1.8.2/lib/logging/appender.rb:139: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/awesome_print-1.7.0/lib/awesome_print/formatters/base_formatter.rb:31: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:27: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:45: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:45: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:48: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:49: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:50: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:52: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:52: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:53: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:53: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:54: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:59: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:60: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:60: warning: constant ::Fixnum is deprecated

Adding verbosity does nothing to extend or add to the output.


Related issues

Is duplicate of Hammer CLI Import - Bug #23058: Warning: lib/hammer_cli_import/persistentmap.rb:27: warning: constant ::Fixnum is deprecatedRejected2018-03-29

History

#1 Updated by Lachlan Simpson over 1 year ago

Lachlan Simpson wrote:

When I run hammer on the cli (discovered against `hammer repository synchronize --id 5 --source-url http://fedora.melbourneitmirror.net/epel/7/x86_64/`, can replicate with `hammer --help`) I see this output before command executes:

[...]

Adding verbosity does nothing to extend or add to the output.

CentOS 7.4, fully up to date, Foreman 1.17.0, Katello 3.6. Both updated from their immediately previous non-beta/RC versions (1.16.1? 3.5.1?)

#2 Updated by Tomáš Strachota over 1 year ago

  • Status changed from New to Duplicate

#3 Updated by Tomáš Strachota over 1 year ago

  • Is duplicate of Bug #23058: Warning: lib/hammer_cli_import/persistentmap.rb:27: warning: constant ::Fixnum is deprecated added

#5 Updated by Daniel Kimsey about 1 year ago

I'm seeing this in 1.18 as well.

[dkimsey@katello ~]$ rpm -qa | grep hammer
tfm-rubygem-hammer_cli_import-0.11.3-1.el7.noarch
tfm-rubygem-hammer_cli-0.13.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-6.el7.noarch
tfm-rubygem-hammer_cli_katello-0.13.5-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.12-2.fm1_17.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.13.1-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-3.el7.noarch
[dkimsey@katello ~]$ hammer --version
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:27: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:45: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:45: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:48: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:49: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:50: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:51: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:52: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:52: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:53: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:53: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:54: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:55: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:57: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:59: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:60: warning: constant ::Fixnum is deprecated
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_import-0.11.3/lib/hammer_cli_import/persistentmap.rb:60: warning: constant ::Fixnum is deprecated
hammer (0.13.0)
 * hammer_cli_foreman (0.13.1)
 * hammer_cli_foreman_bootdisk (0.1.3)
 * hammer_cli_foreman_docker (unknown version)
 * hammer_cli_foreman_tasks (unknown version)
 * hammer_cli_import (0.11.3)
 * hammer_cli_katello (0.13.5)

Also available in: Atom PDF