Project

General

Profile

Bug #23431

clone_vm No :volumes key in args

Added by Sébastien Bernard over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Creation was working OK before upgrading from 1.16.1 to 1.17.

Now every attemps to create a VM yield an exception :

 | NoMethodError: undefined method `first' for nil:NilClass
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:498:in `clone_vm'
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:443:in `create_vm'

I'm joining an extract from the production log with some name expurged.
Some of the messages are in french but they are not critical for the understanding.

This is a copy of the bug #23418 which was wrongly put in kattelo project.

production.log production.log 23.9 KB Sébastien Bernard, 04/27/2018 04:31 PM

Related issues

Is duplicate of Foreman - Bug #23335: Cannot create VM in a vCenter. NoMethodError.Closed

History

#1 Updated by Sébastien Bernard over 1 year ago

A quick analysis shows that the args do not contains any attribute named :volumes.
Thus the call to args[:volumes].first[:datastore] breaks.

#2 Updated by Sébastien Bernard over 1 year ago

  • Status changed from New to Duplicate

At last, it appears to be another dup of #23335.
Bug is fixed by applying the patch.

#3 Updated by Sébastien Bernard over 1 year ago

  • Priority changed from High to Normal

#4 Updated by Michael Moll over 1 year ago

  • Is duplicate of Bug #23335: Cannot create VM in a vCenter. NoMethodError. added

Also available in: Atom PDF