Bug #23435

deleteing org errors: Cannot delete version while it is in environments: Library

Added by Thomas McKay 3 months ago. Updated 8 days ago.

Status:Closed
Priority:Urgent
Assignee:-
Category:Organizations and Locations
Target version:Katello 3.6.1
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link: Found in Releases:
Pull request:

Description

hammer --server https://devel.example.com --username admin --password changeme organization delete --label Default_Organization
Could not delete the organization:
Cannot delete version while it is in environments: Library

Created a new org then tried deleting original.

History

#1 Updated by Thomas McKay 3 months ago

2018-04-28T13:12:44 [W|app|07591] Action failed
 | RuntimeError: Cannot delete version while it is in environments: Library
 | /home/vagrant/code/katello/app/models/katello/content_view_version.rb:331:in `validate_destroyable!'
 | /home/vagrant/code/katello/app/lib/actions/katello/content_view_version/destroy.rb:6:in `plan'
 | /home/vagrant/code/dynflow/lib/dynflow/action.rb:493:in `block (3 levels) in execute_plan'
 | /home/vagrant/code/dynflow/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /home/vagrant/code/dynflow/lib/dynflow/middleware.rb:18:in `pass'
 | /home/vagrant/code/dynflow/lib/dynflow/middleware.rb:35:in `plan'

#2 Updated by Andrew Kofink 3 months ago

  • Legacy Backlogs Release (now unused) set to 352
  • Target version set to 245
  • Priority changed from Normal to Urgent
  • Assignee deleted (Thomas McKay)

#3 Updated by Thomas McKay 2 months ago

  • Status changed from New to Closed

Cannot reproduce on fresh devel forklift

Also available in: Atom PDF