Project

General

Profile

Bug #23620

foreman-installer --reset cannot empty local mongo 3.4 database

Added by Ales Dujicek about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

reset deletes the database this way:

hooks/pre/10-reset_feature.rb
def empty_mongo
        'systemctl stop rh-mongodb34-mongod',
        'rm -f /var/lib/mongodb/pulp_database*',
        'systemctl start rh-mongodb34-mongod'
end

but mongo 3.4 stores data in a different way than 2.6, so this does not work for 3.4

mongo 2.6

# ls /var/lib/mongodb/
journal  local.0  local.ns  mongod.lock  pulp_database.0  pulp_database.ns

mongo 3.4

# ls /var/lib/mongodb | grep -v -e collection- -e index-
diagnostic.data
journal
_mdb_catalog.wt
mongod.lock
sizeStorer.wt
storage.bson
WiredTiger
WiredTigerLAS.wt
WiredTiger.lock
WiredTiger.turtle
WiredTiger.wt


Related issues

Is duplicate of Katello - Bug #23564: foreman-installer --reset does not use mongo 3.4Closed2018-05-11

Associated revisions

Revision 0da32fc6 (diff)
Added by Chris Roberts over 1 year ago

Fixes #23620 - Fix reset for local & remote MongoDB.

History

#1 Updated by Jonathon Turel about 2 years ago

  • Legacy Backlogs Release (now unused) set to 338

#2 Updated by Andrew Kofink about 2 years ago

  • Difficulty set to easy
  • Assignee set to John Mitsch

#3 Updated by Jonathon Turel almost 2 years ago

  • Target version changed from Katello 3.7.0 to Katello 3.7.1

#4 Updated by Jonathon Turel almost 2 years ago

  • Target version changed from Katello 3.7.1 to 931

#5 Updated by John Mitsch almost 2 years ago

  • Is duplicate of Bug #23564: foreman-installer --reset does not use mongo 3.4 added

#6 Updated by John Mitsch almost 2 years ago

  • Status changed from New to Duplicate

Looks like this is a duplicate and is already fixed

#8 Updated by Ales Dujicek almost 2 years ago

  • Bugzilla link set to 1636328

#9 Updated by Chris Roberts over 1 year ago

  • Target version deleted (931)
  • Assignee changed from John Mitsch to Chris Roberts
  • Status changed from Duplicate to Assigned
  • Category set to Installer

#10 Updated by The Foreman Bot over 1 year ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/708 added

#11 Updated by Eric Helms over 1 year ago

  • Target version set to Katello 3.9.0
  • Status changed from Ready For Testing to Closed

#12 Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/Katello/katello-installer/pull/709 added

#13 Updated by Zach Huntington-Meath over 1 year ago

  • Pull request deleted (https://github.com/Katello/katello-installer/pull/709)

Also available in: Atom PDF