Project

General

Profile

Bug #23627

manifest import requires refresh before enabling repository sets

Added by Andrew Kofink over 1 year ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The UI shows the subscriptions just fine, but the RH repository sets page (drilling down the tree to a leaf) shows "No repositories accessible. Check that Red Hat Subscriptions have been imported."

Reliably reproducible on Katello 3.4.5

Workaround: refresh the manifest

This happens not only on the first import, but even deleting the manifest and re-uploading gives the same result.

History

#1 Updated by Andrew Kofink over 1 year ago

This happens when you use a manifest that is out of date. The subscriptions still show up, but the RH repo sets page complains about not having subscriptions. It still seems like a bug to me, as the UI seems inconsistent.

Workaround #2: Go to the subscription portal and re-export the manifest and upload to Katello

#2 Updated by Jonathon Turel over 1 year ago

  • Legacy Backlogs Release (now unused) set to 349

#3 Updated by Greg Sutcliffe over 1 year ago

  • Triaged set to No
  • Found in Releases Katello 3.4.5 added

#4 Updated by Andrew Kofink over 1 year ago

  • Bugzilla link set to 1606228

#5 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello 3.8.0 to Katello Backlog

Also available in: Atom PDF