Project

General

Profile

Bug #23633

Activation keys tab on Hostgroup does not store its value and so kt_activation_keys parameter is not available at host provision

Added by Dirk Götz over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

In the activation keys tab on the hostgrouo I can select the activation key, but when I press submit and open the hostgroup again it seems like the activation key is not stored.
There is also no parameter kt_activation_keys shown at the hostgroup or a host using this hostgroup which results in the host not getting registered as content host via subscription-manager.

Setting the parameter kt_activation_keys directly at the hostgroup is not possible which is intended as far as I understood. Setting the parameter on the hosts works and lets the host register as expected.

In the production.log is no error message, just a 200 OK for the POST /hostgroups which contains the correct activation key in group_parameters_attributes.

Verified on an older test installation with Katello 3.5 that this is only a bug in 3.6.


Related issues

Is duplicate of Katello - Bug #23274: Can't add activation key to hostgroup via UIClosed2018-04-15

History

#1 Updated by Jonathon Turel over 3 years ago

  • Legacy Backlogs Release (now unused) set to 352
  • Assignee set to Jonathon Turel

#2 Updated by Jonathon Turel over 3 years ago

  • Is duplicate of Bug #23274: Can't add activation key to hostgroup via UI added

#3 Updated by Jonathon Turel over 3 years ago

The fix for this (linked it to this issue) is available in master and will be in 3.7 and 3.6.1. Thanks for the report!

#4 Updated by Jonathon Turel over 3 years ago

  • Status changed from New to Duplicate

#5 Updated by Greg Sutcliffe over 3 years ago

  • Triaged set to No
  • Found in Releases Katello 3.6.0 added

Also available in: Atom PDF