Project

General

Profile

Bug #2364

Add a way to regenerate managed host PXE files

Added by Jaroslav Henner about 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I would expect, that when I click on Build PXE default, it would build the PXE menu for both, known as well as for not yet known systems.

For the known host, I have to click and unclick the Build button in order to regenerate the PXE menu after chaning the template.


Related issues

Is duplicate of Foreman - Feature #2267: Need rake task and/or UI button for rebuilding all host tftp config filesClosed2013-03-01

History

#1 Updated by Greg Sutcliffe about 6 years ago

  • Subject changed from Default PXE boot menu of known system is not regenerated to Add a way to regenerate managed host PXE files
  • Category set to Unattended installations
  • Assignee set to Greg Sutcliffe

The "default" button is exactly that, it updates the default file. However, I agree we need a way to regenerate all the files for the managed hosts. I think a separate button is the way to go - "Rebuild Host PXE files" or something like that.

#2 Updated by Simon Wydooghe almost 4 years ago

This is a feature which would be most appreciated. Any update on this by any chance?

#3 Updated by Dominic Cleal almost 4 years ago

  • Is duplicate of Feature #2267: Need rake task and/or UI button for rebuilding all host tftp config files added

#4 Updated by Dominic Cleal almost 4 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

Yep, it's in progress under another ticket: #2267.

Also available in: Atom PDF