Project

General

Profile

Refactor #23665

Use Patternfly charts in Runtime

Added by boaz shust almost 4 years ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
JavaScript stack
Target version:
Difficulty:
medium
Triaged:
No
Bugzilla link:

Description

This is related to http://projects.theforeman.org/issues/22812 and projects.theforeman.org/issues/23010.

The flot chart package is deprecated although Foreman is using it to plot charts.
One of the charts that needs to be migrated is the Runtime chart which is in "app/views/hosts/show.html.erb"


Related issues

Related to Foreman - Refactor #22812: Migrate jquery-flot to patternfly-react chartsClosed
Related to Foreman - Bug #33310: Host Detail Graphs VERY slow to load after upgrade to 3.0.0-rc1Closed
Follows Foreman - Refactor #31595: deprecate flot_chart (timeseries area chart)Closed

Associated revisions

Revision 066f573b (diff)
Added by Ondřej Ezr 11 months ago

Fixes #23665 - Patternfly charts on Host Detail

We are still using deprecated method `flot_chart` to render the Host
detail page charts. It works, but we should migrate to rendering
React components directly.

History

#1 Updated by boaz shust almost 4 years ago

  • Subject changed from Replace flot chart with Patternfly c3 chart in the Runtime chart to Use Patternfly charts in Runtime

#2 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5600 added

#3 Updated by Ohad Levy over 2 years ago

  • Related to Refactor #22812: Migrate jquery-flot to patternfly-react charts added

#4 Updated by Ohad Levy over 2 years ago

  • Related to Refactor #23010: add deprecation warnings to all flotcharts functions added

#5 Updated by Ohad Levy over 2 years ago

  • Related to deleted (Refactor #23010: add deprecation warnings to all flotcharts functions)

#6 Updated by Ondřej Ezr 12 months ago

  • Tracker changed from Bug to Refactor

#7 Updated by Ondřej Ezr 12 months ago

  • Is duplicate of Refactor #31595: deprecate flot_chart (timeseries area chart) added

#8 Updated by Ondřej Ezr 12 months ago

  • Status changed from Ready For Testing to Duplicate

This has been done within #31595

#9 Updated by Ondřej Ezr 11 months ago

  • Is duplicate of deleted (Refactor #31595: deprecate flot_chart (timeseries area chart))

#10 Updated by Ondřej Ezr 11 months ago

  • Follows Refactor #31595: deprecate flot_chart (timeseries area chart) added

#11 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 3.0.0 added

#12 Updated by Amit Upadhye 10 months ago

  • Target version set to 3.0.0

#13 Updated by Amit Upadhye 10 months ago

boaz shust wrote:

This is related to http://projects.theforeman.org/issues/22812 and projects.theforeman.org/issues/23010.

The flot chart package is deprecated although Foreman is using it to plot charts.
One of the charts that needs to be migrated is the Runtime chart which is in "app/views/hosts/show.html.erb"

boaz shust wrote:

This is related to http://projects.theforeman.org/issues/22812 and projects.theforeman.org/issues/23010.

The flot chart package is deprecated although Foreman is using it to plot charts.
One of the charts that needs to be migrated is the Runtime chart which is in "app/views/hosts/show.html.erb"

I can see this is marked duplicate however fixed by combined pr in separate commit. Accordingly I am marking this fixed in 3.0

#14 Updated by Amit Upadhye 8 months ago

  • Category set to JavaScript stack

#15 Updated by Tomer Brisker 7 months ago

  • Related to Bug #33310: Host Detail Graphs VERY slow to load after upgrade to 3.0.0-rc1 added

#16 Updated by Ondřej Ezr 7 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8522 added

Also available in: Atom PDF