Project

General

Profile

Feature #2367

Support Ruby 2.0

Added by Dominic Cleal over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Foreman should theoretically be able to run on Ruby 2.0 now Rails 3.2.13 is used.

Associated revisions

Revision 7735a19a (diff)
Added by Dominic Cleal over 6 years ago

fixes #2367 - Ruby 2.0 support

  • require bundler 1.3, preventing ruby-debug19 getting installed on Ruby 2
  • update 1.9 gems to install on 2.0 too
  • don't use empty arrays in Hash constructor, causes ArgumentError

History

#1 Updated by Dominic Cleal over 6 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to 1.2.0

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF